Exchange ECP HTTP Error 500.19 MSExchangeECPAppPool.config ApplicationHost.config (0x8007000d)

image

Spoiler alert!: IIS keeps history of config files!

Well, Somethings wrong!

2 days ago, I helped the customer deploy their new Exchange 2013.  Everything is fine then, we had OWA and ECP running. Today I was called because they decided to add new mailboxes and cant access the ECP.

As troubleshooting, I opened the IIS Management Console and was presented with this:

image

Opened the File and this came up. My reaction: What’s this!? Config files for aliens?!

image

More background first for troubleshooting:

1. Client Installed .NET Framework 3.5 and ASP.NET 3.5 thinking this is missing.

2. Client Restarted everything. Yea, the have you tried turning it on and off again.

 

So le me, going back to the original problem: the Config file is corrupt!

Good guy IIS, always create a copy of the config history under INETPUB!  So I just go to that folder and under the second to the last CFG History I copied the applicationhost.config.

image

Now go to The Inetserv Config folder under System32 (as the error said and rename the applicationhost with .old so that you have a backup copy of it. Then paste the applicationhost.config here.

image

Back to work now and Happy deployment!

Advertisements

Published by

johndelizo

I'm John and in the daytime I am the Chief Technology Officer of VFTS.NET - a consulting firm that specializes on development and deployment of business solutions created with .NET framework on Windows platform and Windows infrastructure projects. I am a core member of the Philippine Windows Users Group, a contributor at the Microsoft Philippines Community forums and I regularly conduct technical sessions as well as other Microsoft technology events. I am a Microsoft Most Valuable Professional in the Cloud and Datacenter Management Technical Expertise but away from any keyboard I spend hours reading books, travel, explore, and being busy with my dog named Floppy.

2 thoughts on “Exchange ECP HTTP Error 500.19 MSExchangeECPAppPool.config ApplicationHost.config (0x8007000d)”

  1. John, my friend is using this same method to correct his 2013 server on a regular basis, but as of today it only fixed it for a few minutes before crashing it out again. Do you know more about what may be corrupting this config file in the first place?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s